This website uses cookies. By using this website you accept the use of them for our services.
Legal Notice / Aviso Legal

SportDyno 4.0 What's New?

SportDyno V4.0

21/NOV/2017, release 4.0.20:
  • Bug: Step test mode reviewed, target (green circle) never completed the recording time
  • Bug: After a dyno run average HP was 0, but if recalculated then it was ok. Now it is fixed
  • Bug: When TCP was selected, FTDI was still "ticked"

  • 15/NOV/2017, release 4.0.19.2:
  • Bug: XDS TPS calibration was not performed at SD startup, it was necessary to enter the XDS window, click on TPS tab, and then click on main tab again
  • Bug: It was mixing "No" and "no to all" at new message (when closing files)
  • Bug: When a calculated channel was added "for new tests" it was not in the new test. Only after updating channels or closing SD it was adding to all new tests. Now it updates the available channels every time a channel is marked/unmarked as "add"
  • Bug: When applying an user factor of x0.1 to thermocouple input it still applied x1.0 due to a compatibility topic with an old FW. Now it appllies the correct FW selection

  • 09/NOV/2017, release 4.0.19.1:
  • Bug: Relays always toggled with old SP5 FW versions
  • Bug: When testing the new relays function, it didn't worked well back with older FW
  • Bug: ">" and "<" characters were interchanged in sequencer

  • 08/NOV/2017, release 4.0.19:
  • New: FTDI mode added for main COM to provide direct connection, and to improve USB performance (it sets latency to 1ms)
  • New: New relays management (for corresponding Firmware). In this new mode, only changes are transmitted for single relays to prevent the relay status changing in blocks if the previous received status was wrong or not up to date.
  • New: CAN PWS Integration. Pre-test check (PWS connected and faults detected by PWS)

  • 23/OCT/2017, release 4.0.18:
  • Bug: Did not store start and stop values for inertial test mode
  • Bug: Connection (Status) issues, it stayed yellow until PID monitor or Gauges were open
  • Bug: When searching a new COM, if there are no COMs it gets the TCP, even if it is not visible (confusing)
  • Bug: When the file is stored, there was no HP and TQ data in the internal data (but it was being recalculated)
  • New: When adding a calculated channel, it should be enabled and selected automatically

  • 20/OCT/2017, release 4.0.17:
  • PID monitor works slowly when there are big controls at gauges window (even if they are not visible). Now controls that are not visible are moved, and excessive big controls are reduced
  • SD4.0 vs SP3 compatibility issue. Now SP3 is detected and recorded as expected
  • Analyzing causes of glitches. Data timeout increased to 800ms. It is strongly recommended to change USB driver latency to 1ms
  • Presets did not work ok for AFR and lambda
  • After grouping tests several times, colours change

  • 16/OCT/2017, release 4.0.16:
  • Bug: If SP5 communication is lost during the connection process, the icon did not go back to disconnected/red
  • Bug: Review 2 roller / 1 axle mode: added 2nd diameter and number of teeth
  • Bug: Engine dyno tests sometimes showed "-INF" at HP engine field: "28.7 (-INF) / 12355"
  • Bug: Did not show GPS during track simulation (the first run)
  • Bug: GPS graph was not shown for negative LON (USA)
  • New: Adding a ratio channel as a provision of variable ratio tests, for instance if ratio is changed during step tests

  • 6/OCT/2017, release 4.0.15:
  • New: maintenance notice (now set to 150 tests)
  • New: Added a relay column at CSV simulation file (5th column)
  • New: Enable a fixed throttle automatically with start of test for engine dyno
  • New: Sequencer:
    • Encrypted / Binary sequencer files
    • Hide all Sequence file (when encrypted file)
    • Split header in 3 colums: Variable, Value, Comment (variable not editable)
    • Update Sequencer help
    • Bug: Review sequencer instructions to allow the usage of variables in all of them, for instance RAMP was not updated
  • New: Review Password levels: Demo, Beginner, Normal (default), Administrator
  • New: Add a max rate constraint to avoid hard brakings (engine dyno)

  • 29/SEP/2017, release 4.0.14:
  • New: Big buttons have been integrated in the toolbar to allow to use smaller Monitor
  • New: Sequencer file is now parametrized. In the header section there are labels defined as "$label", and these labels can be used along the sequencer (MIN_RPM = $label). When using parameters the seq file the lines remain grayed (not editable)
  • New: Direct button for steady and ramp (Modes)
  • New: add new safety-relays support to SW
  • Bug: CAN:
    • max id: it was limited to 23 bit. Now it allows 29 bit
    • CAN id now can be decimal or hex (0x….)
    • sign attribute: it was not imported correctly
    • First allowed channel was 0x91, now it is 0x90"
  • Bug: improve acceleration calculation and checksum errors (if a sample was not ok it appeared a glitch in the accel, now the SW fixes the faulty sample)
  • Bug: When pressing F12 to close throttle, it also shows the printer Window
  • Bug: When trying to open some 3.8 files on 4.0 it showed automation error
  • New: Remove decimals from load cell calibration Window (N*m)
  • Bug: Review ratio function (3.8 only calculates ratio when accelerating)

  • 12/SEP/2017, release 4.0.13:
  • New: (PWS with CAN) Addeded manual tests for checking the connection (SP5 to PWS to Brake), this is specially useful on AWD dynos as it is necessary to know that both brakes work before the test. This is part of a bigger diagnostic system that is being developed.
  • New: Added "Yes to all" and "No to all" options to the unsaved files check. Note: language files contain only English, Nederlands and Spanish translation for these buttons.
  • New: "Using MAX_RPM and MIN_RPM names as variables in Sequencer. Examples: REF = MIN_RPM. Wait ch < MIN_RPM"
  • New: "Max Values" Summary Window, now it can be moved / dragged
  • Bug: "manage folders" setting was not stored
  • Bug: check that folder names do not have spaces
  • Bug: Continuous Update checkbox showed enabled but it was not (and did not update)
  • Bug: Yellow popup shows bad text when it is too long

  • 6/SEP/2017, release 4.0.12:
  • New: Power Supply Feedback (CAN) added at PID monitor window. This is part of a bigger diagnostic system that is being developed.
  • Bug: Didn't store traction mode, only single axle/awd. It uses it now for recovering test details (when necessary)
  • Bug: Version 4.0.11 applies target RPM=0 when setting inertial mode in direct mode (default is guided mode)

  • 4/SEP/2017, release 4.0.11:(do not download)
  • Bug: Ramp didn't stop in "direct" mode (in guided mode it stopped)
  • Bug: When edditing the test number in "folders" mode, the Special characters error was reported (it should not take into account "\" or ":" from the full path).
  • Bug: After doing a test sometimes the cursor is floating
  • Bug: New CAN channels were not available in Sportdyno (only at 4.0.10), only at Ext Channels Window
  • New: Min CAN update rate set to 15 ms

  • 31/AUG/2017, release 4.0.10:
  • New: When changing FWD, RWD, AWD now it verifies that the command has been received and the new channels are updated
  • New, CAN: channel Ids are assigned in the ECU descriptor file, so each (predefined) channel has always the same ID
  • New: Added option to disable inertial mode (advanced options)
  • Bug: Splitter lines (Main Window) were not visible after entering the configuration window
  • Bug: Print: number colors and graph colors do not fully match (did not apply 'dark print' setting)
  • Bug: LP Filter only stored 0 or 1
  • Bug: Did not store the "continuous update" setting for ratio mode
  • Bug: yellow box/secondary mode needed two clicks after hidding tests(3rd pass)

  • 24/AUG/2017, release 4.0.9:
  • Bug: It did not apply changes on filters from the button at main configuration
  • Bug: the "HP and TQ start at min values" option did not work on tests without losses/coasting
  • Bug: the horizontal grid lines and the HP scale disappear when enabling and disabling seveal channels
  • New: The "MAX" button is now hidden by default, and can be enabled at config / advanced options
  • Text mistake: Looses -> Losses
  • Bug: Emergency Stop + Config Export = modal form error
  • New: option for taking test configuration from latest loaded file (ramp settings, ratio, etc)

  • 22/AUG/2017, release 4.0.8:
  • New: arrange folders from the test name/details. IF ACTIVATED: Sportdyno will create folders for every Brand/Model/Customer
  • New: "Max" button added (it shows similar info to test grd but simplified and a little magnified, in the center of screen)
  • New function: Power increase (0%, 5%, 10%)
  • New, CAN: Change "Get RPM form OBDII Channel" ? to "Get RPM from ECU Channel" (OBDII, CAN, xDS, etc...)"
  • New, CAN: CAN listener now identifies the first channel called 'engine rpm' or 'engine speed' from ECU definition file to be used as Engine RPM at Gauges and Ratio windows
  • New: yellow box/secondary mode needed two clicks to activate both tests, now it selects the first two
  • Bug, CAN: Selected chanels are added to test, but with the wrong label/name. Now it renames the Main Channels names to the channels from the CSV file.
  • Bug: Hours counter was not being updated
  • Bug: Secondary Test: after X value it showed '????', now it is empty
  • Bug: Yellow box ghosts (when secondary test is enabled)
  • Bug: When more than 8 tests are in the SW and group colors by test was select, colors were not right
  • Bug: Problem with RAMP min/max rpm: sometimes it did not remmember last setting. The problem happened when changing the tab while one of the fields was being edited
  • Bug, CAN: String in ECU listener didn't reflect real values as each ECU definition file can have different channels at the fixed SD positions. Now it is just a composition of first 3 channels
  • Bug, CAN: the gauge on the right display "RPM ECU" from CAN with the wrong name and a non updating value
  • Bug: Printer Configuration: test columns button didn't open the window

  • 10/AUG/2017, release 4.0.7:
  • Bug: When traction mode was AWD, it was not selected at gauges window next time the window is entered (although it was internally selected)
  • Bug: Translate "only Front, Only Rear…" to each language
  • Bug: When using the thermometer control for lambda it worked badly (due to starting offset at 10 AFR)
  • Bug: ramp min rpm went to 0 after entering Step Test and going back Ramp
  • Bug: sometimes "teeth2" changed to 1, in AWD mode
  • Bug: Bad speed translation at configuration from roller rpm fields
  • New: default min roller rpm = 700 RPM was too high for 505 mm rollers, now is 200 RPM
  • New: now does not show _bak files when loading a test (added another filter for them)
  • New: Graph & scales Line Thickness added to configuration
  • Bug, CAN: when pressing OK at the 'ECU Listener Channel Selection' window, the main External COMMs was also closed, now, when pressing OK, it comes back to External COMMs window
  • New, CAN: setting added to tell the SW if the CAN listener has to be activated on startup or manually to prevent problems with the ECU (if baud setting was changed)
  • Bug, CAN: Each time you opened "External Data Source" windows from "can listener", SD activated ON a channel by itself (the next from your last selection, or the first one if this is the first time you open this windows).
  • Bug, CAN: Also, sometimes when selecting channels, they were not put in SD "channel" main windows
  • Bug, CAN: Can Listener only took data from M.S. addresses (an internal filter was active, but not re-configured by SW), now the address filter is disabled to allow the full range
  • New, CAN: warning added "Please Note that using inapropriate baud rate may stop the communications between the CAN devices"

  • 20/JUL/2017, release 4.0.6:
  • When using the Ratio Window, after the ratio is determined, now the program ensures that rpm is at a good value (lower than the "pre-charge" rpm, before commanding steady mode
  • Speed / RPM setting now applies for each control by sepparate, not for all as before
  • (bug)Gauge controls had big delay, while scroller only had about 1 sec. Probably due to slow updating freq
  • (bug)Printing issues: "5252 rpm" option didn't work correctly. Now the tests are recalculated and the maximums calculated before dumping the graphs
  • (bug)Printing issues: "5252 rpm" option didn't enable again the "min values" frame at config window (it was mixed with the main 5252 rpm option)
  • (bug)When the starter relay was commanded with Shift-F2 it finally switched off (internal timeout) but it did not update the button status, but only when it
  • (bug)Printing issues: after printing, the SW changed always to "add losses" mode (did not restore the previous status)
  • (bug)Fields inertia1, teeth1 and diameter1 where not correctly stored (mixed with axle 2)

  • 6/JUL/2017, release 4.0.5: (link removed)
  • (bug)When doing new tests, previous tests show power = 0, although graphs were ok. After re-calculating they showed right values
  • (bug)After first test HP and TQ scales were wrong. After recalculating they were ok)
  • (bug)Gauges: Green needle (peak value) did not move
  • (bug)When restoring gauges the window remain empty
  • (bug)Default Engine RPM gauge should include PID Ref channel as 2nd neddle
  • (bug)OBDII status icon was not updated in the OBDII window, if the OBDII window is opened after the connection
  • (bug)When printing to a XDS printer (Microsoft) and cancelling the operation it caused an error

  • 29/JUN/2017, release 4.0.4:
  • Added Engine RPM Divider combo (same as for Engine gauge), also at Engine RPM tab
  • Foxed strange jumps in the PID fields (sometimes to zero)
  • Adding controls to empty gauges window could raise a runtime error, now additional protection to accessing the selected 'control' variable has been added
  • Weather Station warning message could cause a runtime error if other modal window was open, now additional protection before showing new forms has been added
  • Control names were badly shown when the channel is assigned FIRST time
  • After deleting a test it asked if you want to write it (didn't make sense), now it does not ask it
  • It were numbering issues when the "generate test name" function was active (name didn't include the auto-increment number)
  • Stored HP and TQ values are now used until the test is edited to keep the original HP and TQ values created with the test (to prevent unnecessary recalculations to do little changes in readings across different SW versions)
  • SP3: test mode issues (it showed ramp mode details, even if inertial was initially selected)
  • SP1, 1-pulse per rev caused issues at low speeds
  • Weather Station: Direct FTDI Search to avoid searching across several COMs
  • Now SW has re-arranged certain channels as cell1 and cell2 that were not consequtive (with respect their IDs / keys)
  • Issues when tracking in rpm mode, specially for coasting graph, fixed
  • Optimized end of filtering to get a longer aailable data (it uses filter / 2 at the end)

  • 30/MAY/2017, release 4.0.3.3:
  • PID monitor: add "properties" popup menu for scrollers
  • Scrollers: colours Assignment (according to channel's colour) and re-arrangement of scale numbers
  • When resizing a scroller or other combos, sometimes the control did not take the new size (specially at window resize event)
  • Removed 'group' combo from channels menu (group field), now there is only a group number
  • When editting a gauge or control, sometimes the channels list is empty, it has been added an 'update' button to get the channels list
  • Management of Negative load cell coefficient at SP5 side (changed from unsigned 16 to signed 15)
  • When changing from engine dyno to vehicle dyno, the RPM vs KMH scales were not updated properly

  • 23/MAY/2017, release 4.0.3.2:
  • New function to Discard load cell channel during coasting. Some old dynos have strong vibrations during coasting. This function provides a clear output for the power losses graph when added to the wheel power

  • 22/MAY/2017, release 4.0.3.1:
  • Gauges/Ratio tab: Button for acquiring ratio in clamp and ECU modes
  • Gauges/Ratio tab: Checkbox to enable continuous acquiring (normal way in inertial operation)

  • 20/MAY/2017, release 4.0.3:
  • Scroller operation debugged (channels and updating speed)
  • Re-arrangement of presets now channels have a channel type (hardware) and a user type
  • Blocked scale for not editable channels (OBDII, etc)

  • 11/MAY/2017, release 4.0.2.4:
  • PID monitor: added splitted windows to allocate load cell channels and AWD roller diff for monitoring during system installation
  • When a new box is added now it is applied a default size depending on its type
  • When a file from the RFL was not in the disk it created an empty file. Now it shows a message and does not create the empty file
  • Additional German language review

  • 8/MAY/2017, release 4.0.2.3:
  • Did not show the background gradient correctly on big screens
  • Did not load background
  • Added "stop engine" option to gauges window
  • Wrong roller RPM (speed). Now only roller rpm for engine dyno type
  • Nederlands Language: bad "upload logo" sentence (msg 660 was bad)

  • 3/MAY/2017, release 4.0.2.2:
  • With white background and "group tests" mode, X-axis was sometimes too light
  • Compatibility issue SW4.0 with FW2.30 or earlier (debug KP_R setting)
  • STEP TEST modified to acquire the friction losses / coasting (note than step test did not use inertia!)

  • 29/APR/2017, release 4.0.2.1:
  • Printing bug: it was showing channels that should be filtered
  • Printing bug: runtime error when one file and no data table
  • SP1 vs SD4.0: bad HP -> prescaler was not considered for SP1 during the acceleration calculation, and thus torque and power
  • Config window, Consolas font issue: added the err.description message to clarify
  • More language review (German and French)
  • Max Engine RPM / Max Calculated RPM added at test file details (in case Engine RPM Channel is 0)
  • Emergency Stop and AWD Sync error Messages have been moved to a different window to allow "always on top"-type message

  • 28/APR/2017, release 4.0.2:
  • Review / Arrange Load Cell config and teeth info to ensure F/R/AWD sub-modes
  • Dyno name / profile added to test info
  • Problems when changing from SP4 to SP5 with the prescaler. It is not updated from 4 to 1, or oposite
  • Change the profiles per transmission type (Front, Rear, AWD) by a sub-type on a single profile (AWD Dyno-subtype: front)
  • SHIFT+Fx fails sometimes
  • Errors when closing the SW
  • Button + led state for adding losses
  • CAN: Authentication problems
  • Print HP units (mechanical or metric)
  • Show delta time in average HP (from starting RPM to ending RPM)
  • Does not load correctly recent tests when the current folder is not the same
  • Recent recorded tests are not shown in the Recent File List
  • Connections that end in "red" state

  • 25/APR/2017, release 4.0.1.46:
  • Clutch Peak Filter added (when the coasting has an initial peak)

  • 24/APR/2017, release 4.0.1.45:
  • Support for AWD Sync error message (it needs the FW updated to be displayed)
  • (bug) Average power sometimes showed bad output
  • (bug) Slow down ramp was not correctly applied at the end of an inertial test
  • "Gauges Always On Top" new feature
  • Align relay and thermo (channel) names between sw and hardware and manuals
  • Deep review of language files: internal code messages and untranslated windows as OBDII and xDS have been added to lan files
  • Road Simulation Support. Started, not yet available (SP6)
  • When configuration password is active all config fields are disabled except the printer options
  • "Disable feedback" (bad) text in the "semaphore" window

  • 11/APR/2017, release 4.0.1.44:
  • (bug) RPM target and THR were not updated correctly in seq. Status
  • Remove load cell warning message when negative scale is used
  • "Emergency Stop Activated" message was not shown in SD4.0
  • Field "km/h" did not work at Test Grid (no values: 0)
  • Cutting tests did not work

  • 6/APR/2017, release 4.0.1.43:
  • Weather Station: Support for "Question & Answer" protocol to prevent Ballpoint device issue (Windows issue)
  • Default "C:/Temp" folder changed to "C:/Dyno Tests"
  • PID monitor window also locked with password (when configuration is locked)
  • Configuration: "upload logo" button added
  • Alerts are also exported in the configuration file
  • Step Test reviewed to support AWD dyno

  • 31/MAR/2017, release 4.0.1.42:
  • Unicode chars in the yellow label
  • Changed RPM Step rounding to 50 RPM
  • 2nd load cell channel got corrupted when loading the test again, and during Dynorun recording HP was not shown
  • When doing new tests, from some point the scales were wrong during test, but after the test they are ok again

  • 22/MAR2017, release 4.0.1.41:
  • When closing sequencer status, sequencer does not stop
  • "keep colours" function in graphs for grouping tests (colours were inverted with respect the test list)
  • "Slow down" function after test is disabled for sequencer program
  • Sequencer: in a test loop it only recorded the first test
  • Big resolution (2560
  • 1600) showed error 6-overflow, but lower (2048
  • 1536) did not
  • Sequencer did not stop if you stop it manually, It keeped recording
  • If test color is yellow then text can not be read in table
  • Clamping for Input data (max value) did not work
  • Gauges: speed combo lost its control when control moves
  • Wheater station had some issues (disconnected, and COM search was too short)

  • 14/MAR/2017, release 4.0.1.39:
  • "5252 RPM" crossing point Issues in both: non losses and losses graphs, due to filter de-phases
  • Language reviewed, Unicode support through a license
  • NEW: Increased resolution of printed report
  • When changing profile and Gauges are open, load cell scale were not updated until it is opened again
  • Editting Sequencer: now saves before run or before closing
  • NEW: Print each test in one sheet (when group option is disabled)
  • ECU: it added too much ECU "spare" channels to the test (did not update the ECU listener before the test)
  • Added Output Speed Target Channel (beta)
  • NEW: New group CAN in popup menu (right mouse over graphs), ANA channels were all together
  • view/hide tests issue (tick on grid list)
  • Average test. Wrong RPM channel

  • 15/FEB/2017, release 4.0.1.38:
  • Sequencer was changing to CSV/track type when "WAIT_CH" operation was executed
  • Test mode could be changed using function keys even when the test was running
  • NEW: Test results are stored to a DB-like file (CSV)
  • Steady Mode: steps with pg up/dn are rounded now to 100 RPM not to step value (step=500, before: 3222 to 3500, now: 3222 to 3700)
  • Gauges: Combo RPM/Speed did not work good
  • Gauges: Rollers Speed Gauge did not apply text when switching from RPM to Speed. It always showed RPM text
  • xDS channels dissapeared when CIO (CAN) channels are active
  • It did not load old tests (earlier to SD 3.x)

  • 2/FEB/2017, release 4.0.1.37:
  • NEW: Brake is activated with F9 + fixed SW setting for vehicle "installation"
  • New ECU files have been verified with an external CAN interface
  • NEW: Add raw column to CAN-ECU Listener
  • Default CAN Data (Kb and ms) was 0, also when zero it shows an error but it was not clear that this is the cause
  • NEW: Added a "(none)" entry in the ECU def. files

  • 30/JAN/2017, release 4.0.1.36:
  • Verify CIO connectivity and new ECU files
  • Step test: Remove ramp mode (when ramp=0)
  • Activation / desactivation of tests (visible) works bad on installed version
  • When printing in "screenshot" mode the scales are not the same as for main window
  • Average power calculation resulted in 0.
  • Average File does not work
  • Power losses were added up twice on print-out.
  • xDS channels are not active on startup. Always have to go to XDS window so they become active
  • RELAYn=ON did not work (RELAYn=1 did work)
  • Printed report does not show the right power at the very final TOTAL
  • Report starts at 0 rpm (it used non filtered data)
  • Add "Show/Hide All Tests" to Test menu
  • Add "Hide All Columns" to grid
  • Password protected config, so other users cannot change config

  • 19/JAN/2017, release 4.0.1.34:
  • RPM / 2 Issue at gauges vs semaphore window
  • Auto pause for step test
  • STEP Map for StepTest (Auto and manual) Timer / load time
  • After a step test if the Sequencer is opened it gets corrupted
  • New tests do not have "static losses" info
  • Activate Step Config again
  • Load cell zeroing was wrong
  • Some windows (gauges) are bigger that some screens (new laptops with 700 height)
  • Runtime error while trying to add new row at the very top of the sequencer
  • Runtime error while trying to delete a row at the bottom of the sequencer
  • When updating the maximums for roller or engine, update also the associated variables

  • 12/JAN/2017, release 4.0.1.33:
  • Test Ratio did not work for inertial mode
  • Sometimes after doing a test, the graphs are not selected and HP or other channel has to be selected. Also tracking is sometimes lost
  • After printing colours of channels had changed
  • Problems when updating colours on existing test
  • Activate all/disable all at Test Average Window
  • Sometimes it hangs when reconnecting the Weather Station (related with Microsoft Ballpoint Device). It comes to life again when disconnecting WS
  • Realtime channels related to power didn't work in gauges window, or when loading the test
  • Realtime channels (all) didn't work
  • Report: disable 2nd chart
  • It was not sending Authentication commands (AWD activation)
  • Error when closing config caused by Recent files that start by numbers (language function)
  • detect forbidden characters (/ ?
  • etc) in filenames
  • Show alarm when the WS is unreacheable
  • CIO308 scales added to Registry

  • 26/DEC/2016, release 4.0.1.32:
  • Scroller does not have decimals in scale
  • """Ghosts"" in the secondary test mode when tracking
  • Automatic backcolor and forecolor for "black" boxes
  • For SP1. When I put number of teeth it does not update prescaler
  • When recording OBDII channels, it records all 48 channels (spares too)
  • When clicking between auto and SP5 and bottom menu dissapears
  • Save picture mode it doesn't show same view as on pc screen
  • (NEW) Create a combo for the ECU listener definitions
  • Load config loads all profiles, but if file has only one profile it has to add it at the end
  • Save config saves all profiles.
  • Delete profile deletes last item in Registry, not selected one
  • Compatibility HP differences 3.8 with 3.7
  • Ratios / brand / model, recent list
  • lower bound configurable to auto but > 0
  • Having several Dyno profiles / Pictures to ease Dyno setup


  • .
    .
    .